+31 (0)24 820 00 00

Belangrijk: Per 19 oktober is het gebruik van PHP 5.4 niet meer mogelijk

Om een zo veilig mogelijke omgeving te bieden is het soms ook nodig om oudere softwarepakketten te vervangen en nieuwere versies te gebruiken. Het liefst doe je dit natuurlijk zo snel mogelijk nadat een nieuwe versie beschikbaar is gesteld, maar helaas is dat niet altijd mogelijk. Nu gaan we wel afscheid nemen van een oudere versie van PHP, PHP 5.4, om de veiligheid van je website te kunnen blijven garanderen. We leggen je in dit artikel graag uit waarom.

PHP logo

Waarom upgraden we nu?
In voorgaande blogberichten hebben we al aangekondigd dat we PHP 5.4 moeten gaan upgraden. Want we streven ernaar om je een zo veilig mogelijke omgeving te leveren. De officiële ondersteuning voor PHP 5.4 is sinds 3 september 2015 stopgezet. Dit is dus al meer dan een jaar geleden. Dit betekent dat er bij beveiligingsproblemen geen updates meer uitgebracht worden om deze op te lossen. Wij kunnen hierdoor de veiligheid van een omgeving niet langer garanderen op PHP-versie 5.4.

php-supported-versions

Wat betekent dit voor sites op PHP 5.4?
Sites op PHP 5.4 worden per 19 oktober 2016 door ons omgezet naar PHP-versie 5.6. Als je nog sites hebt die draaien op PHP 5.4 dan word je hier persoonlijk van op de hoogte gesteld. Wij raden je aan om zélf op een geschikt moment de PHP-versie te veranderen naar minimaal PHP 5.6, zodat je direct kan controleren of alle sites goed blijven functioneren. Dit moet je dan wel voor 19 oktober 2016 doen. Je kunt dit zelf eenvoudig regelen via admin.savvii.nl. We hebben een tool gebouwd waarmee je heel overzichtelijk een of alle sites tegelijk kunt upgraden. De kans dat hierdoor jouw site kapot gaat of problemen gaat vertonen schatten wij als laag in, maar we raden je wel aan om zelf goed te testen.

In ons blog over de aankondiging van PHP 5.6 hebben wij ook stappen beschreven die je kunt nemen om jouw code te controleren mocht dat wenselijk zijn. We raden aan je sites zoveel mogelijk bijgewerkt te houden, omdat nieuwe versies vrijwel altijd ook betere performance opleveren. Lees hierover meer in ons onderzoek over de verschillen in snelheid tussen PHP 5.6 en PHP 7. De upgrade tool werkt je website bij naar versie 5.6, want dat geeft de meeste zekerheid dat alles goed gaat. Een handleiding voor het bijwerken naar PHP-versie naar 7.0 kun je op onze ondersteuningspagina’s vinden.

Wat kunnen jullie zeggen over PHP 7.1?
Evenals het stoppen van ondersteuning voor oudere versies, willen wij vanaf nu ook zo snel mogelijk na het uitbrengen ondersteuning gaan bieden voor nieuwere versies. De aankomende PHP 7.1 versie wordt verwacht op 3 december 2016. Onder voorbehoud van onvoorziene problemen of veranderingen in de genoemde datums, verwachten wij voor het einde van dit jaar PHP 7.1 aan te kunnen bieden.

Nog vragen?
Laat het ons weten! Wij beantwoorden graag jouw vragen of zorgen.

Update 4-10-2016:

Er is een kwetsbaarheid ontdekt in PHP 5.4. Deze gaat dus niet meer door PHP zelf opgelost worden. Des te meer reden om dus z.s.m. zelf al over te stappen naar de veilige versie van 5.6 of 7.

Tweet about this on TwitterShare on LinkedInShare on Facebook

Reageer

(wordt niet getoond)
(wordt niet getoond)
* verplichte velden

Terug naar overzicht

Wij werken met:

  • rackspace_savvii
  • New Relic
  • nginx_savvii
  • Varnish
  • Mandrill
  • Freshdesk